Announcement

Collapse
No announcement yet.

Illusive Firmware

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Illusive Firmware

    Hello all,

    I have xPrinterServer running Firmware version 1.0.0-64, PN 080-470-001-R Rev. A11. I have looked over the manual and specifically at page 34 for the Firmware update process. I have logged in as Admin, executed the process 4 times and to no avail for the upgrade.

    Additionally, I have went to: https://www.lantronix.com/products/x...docs-downloads to see if there was a download for a Firmware updater tool and Firmware. I did not find any tools or firmware for the grade. In the post; https://forums.lantronix.com/forum/x...int-from-ios-7 , there was a reference to download an App from the Apple Store to assist in the upgrade of the Firmware. This did not work for me. I got a message on the iPhone (8+) saying, the app did not allow Firmware upgrades.

    This leaves a few questions - 1. Is the device upgradeable? 2. What version of Firmware should I be looking for? 3. Where do I find the Firmware? 4. How do I install the Firmware?

    I would also like to add another printer which was not found in the Auto-Discover.

    Thanks

    Last edited by 3DES; 05-17-2018, 03:33 PM.

  • #2
    Hello 3DES,

    The unit you have is a older xPrintServer, (out of warranty); However, when in as the Admin log on, and under Admin and firmware on the left side you should now be upgraded to 1.1.0-71 version, except it if you aren't already on that version. If logging in still shows 1.0.0-64 clear your browser cache and log back in. After this version you will need to download the xPrintServer App from the apple store onto a iphone or iPad to upgrade to the higher version software to work on anything IOS 8 or higher.

    This link will walk you thru the upgrade http://ltxfaq.custhelp.com/app/answers/detail/a_id/1779

    This will upgrade you to the 3.3.0-4 firmware, which is the highest that model can go.

    As to adding the printer, all supported printers can be found by clicking [HERE]

    If your printer is not on the list, let me know what the printer Make and model is as the printer may not be supported depending on a number of factors.

    Comment


    • #3
      Thanks for the quick reply! I have cleared the cache (Win 10, IE 11, CTRL-F5 & did opened the; Gear, IO then Delete). I shut my browser down and re-opened it... to the IP of the xPrintServer. I am able to login, I see the menu under admin and selected the firmware update. It tells me there is a firmware update available, I click ok to do the update, it counts down for restart and comes back up with the same firmware (1.0.0-64).

      Thoughts?

      Thanks

      Comment


      • #4
        Are you trying this from an iPad or iPhone? Instead of a computer?

        Comment


        • #5
          I have tried both... and more. Per my original note) A Windows 10 computer, iPhone 8 plus and iPad are the devices I have tried. I am able to login and attempt the upgrade but it does not update the firmware. The device reboots and reports 1.0.0-64 after the reboot. Frustrating!

          I am pretty descriptive in my post. Please let me know my f you need anything else. Thanks
          Last edited by 3DES; 05-27-2018, 05:14 AM.

          Comment


          • #6
            It sounds like something on the network might be blocking the firmware update.

            Are you running this from home or the office? (If at the office you might try from home to see if something might be blocking the firmware download, like a firewall, or anti-virus.)

            Try the upgrade procedure from this link http://ltxfaq.custhelp.com/app/answers/detail/a_id/1779

            If you cannot find the xPrintServer from the APP, then will need to follow this last method.

            This last method has potential to brick the unit, so I bring it up, with the try at own risk. (The xPrintServer your have is most likely out of warranty, even if bought recently, because of the firmware version. The xPS hasn't had the 1.0.0-64 firmware version on it in over 3 years and those models only had a 1 year warranty.)

            Go to firmware under the admin group.

            1. Hold down the shift and click firmware update.
            2. You will be prompted for a password. Put in Prod310
            3. Even when it claims it's done leave the xPS alone for 25 minutes. (The unit is still unpacking files for the backend.)

            4. Reboot the unit after 25 minutes and you may need to clear the browser cache.

            That should get to 3.3.0-4 the latest firmware.

            Note: This last method is very tricky and if fails there is no recovery if it fails.

            Comment


            • #7
              I have followed the upgrade instructions which was provided in the link. These instructions didn't work :-(

              However, you brought up a really good point about the firewall and the virus checking applications. On the Win 10 computer, I disabled all the Firewall, Anti-Virus suite, cleared the browser cache and re-executed the firmware upgrade. The xPS came back up with the 1.0.0-64...

              Without putting a sniffer to monitor this device (xPS)... Is there a TFTP or UDP service you are trying to broadcast to the xPS? Can you send me the firmware (I would assume a .bin) so I could just do it manually?

              Thanks

              Comment


              • #8
                When checking for firmware does it say that the new firmware is available but shows it is going to be 1.0.0.64? If you have an option to upgrade try to upgrade and see if the unit then comes back with 1.0.0-71 firmware? Until that unit is on 1.0.0-71 nothing can be done for upgrading the unit.

                Unfortunately, there are no .bin files for firmware for the XPS. Although that was going to be a method to upgrade it was stopped as a method due to crashing of the XPS due to delays in sending the file. The only method for firmware upgrade is pulling the firmware down from the cloud by the XPS itself.

                1.0.0-64 has to be upgraded to 1.0.0-71 to be able to load any firmware beyond it.
                1.0.0-71 to 3.3.0-4 upgrade is done from the xPrintServer APP due to the size of the file.

                Comment


                • #9
                  I got some screen shots of the adapters configuration web page and what it is reporting back for the firmware updates and configuration... I tried to upload them and it is not allowing me to post them :-(

                  To answer the question about the version upgrading (-71). The xPS does report there is a firmware upgrade available, it does not tell me the version in which it is wanting to download...

                  I have also made certain the following were done:

                  1. Firewall and Anti-Virus is disabled
                  2. The browser Cache was cleared
                  3. The browsers I used: IE11, Edge and Chrome to attempt the upgrade

                  To Note:

                  I have download the app on to my iPhone 8+. The app does see the xPS and I attempted to update the firmware via the app but get an error message stating the version of xPS does not support the firmware update (which is documented).

                  Comment


                  • #10
                    You cannot upgrade the unit until on 1.0.0-71. So it tells you there is an update and you update. Then When you log back it the version is still showing 1.0.0-64? Have you cleared your browser cache to make sure the display is updated?

                    If not please try from a different network to see if something else is blocking the download.

                    Comment


                    • #11
                      1. As described before in my pervious post, I have cleared the browser cache each time I worked with this xPS. Additionally, I have even looked at the xPS with different browsers (IE11, Chrome and Firefox)… so, I think I can safely say it is NOT a browser cache issue.

                      2.. For the network; do you suggest another test we can try? I only have access to my network... BTW: My network seems to be pretty good, it does all things I ask of it. The xPS is seems to be the only update which will not execute correctly.

                      3. At his point, I am willing to send you the adapter to execute the firmware upgrade...

                      Comment


                      • #12
                        If you don't have the ability to try the upgrade from another network, at this point the next option would be to attempt a factory reset on the xPrintServer if you haven't already done so. To reset the device back to factory defaults there should be a pin hole on the underside of the device. use a paperclip in the hole to hold the reset button for about 20 seconds, release and the xPS should reboot. With the older units such as the one you have there, they tend to respond well if you do 3 factory resets in row, you might want to try that then attempt to load the firmware.

                        Comment

                        Working...
                        X