Announcement

Collapse
No announcement yet.

XPort -05AR, right-side LED flahsing amber/green, can't discover

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • XPort -05AR, right-side LED flahsing amber/green, can't discover

    I have new pcbs each with an xport attached. i tried using deviceinstaller to detect and setup the xport, but they aren't being detected.

    The right-side light on the xport is alternating between amber and green, a pattern not shown in any of the documentation (amber-green-off, amber-green-off, that pattern repeating), with or without an ethernet cable plugged in. I have the device connected to an rs-485 transceiver, connecting gpio1 as transmit enable (except I can't setup the xport since it can't be detected via ethernet, so i haven't been able to try uart comm yet). in my bench tests this worked fine: i would program a gpio as the 485 transmit enable, and then serial communication works fine. i have a pullup on the reset line, in my bench test i just tie this directly to 3.3V which worked. So i tried removing the pullup resistor and that did nothing. I tried shorting reset directly to 3.3V like in my bench test and that didn't help either. The only indication I have, other than the right-side LED (which isn't documented well enough to tell me what the pattern means) is that the xport seems to be rather warm. I don't know if these things normally run on the warm side, or if it means something is shorted.

    In any event, i have this alternating LED, and unable to discover the xport in device installer.

    the model number of the xport is XP1001000-05R.

  • #2
    Multiple things come to mind.
    First, RESET should NOT be pulled up. Your CPU can assert it to 0V to start reset, then release to 'input' or high-Z state. The RESET line has an RC network on the line and needs to otherwise float.
    Left side off. Right LED solid
    Amber - polling the serial port
    Green - loading from SPI

    Sounds like it's in a reboot loop. Pull it off the board, and try it on the Lantronix evaluation board.

    Comment


    • #3
      Originally posted by garry0427 View Post
      Sounds like it's in a reboot loop. Pull it off the board, and try it on the Lantronix evaluation board.
      Like I said, I tried pulling off the pullup and I tried shorting to +V, which is what I do on my bench test unit, where my test unit works fine. So it appears to not be a problem with the reset line, otherwise it would be working after i pulled the resistor.

      Comment


      • #4
        Do not pull up or short to VCC.
        Monitor VCC while booting. If stable at 3.3V and the device does not boot - remove it and request an RMA through tech support. The only way I can rule out your board, is to take it off and see if it works 'on the bench'. If not, RMA it.
        It also should not be 'hot' - warm is normal, hot is not. Was the part hand soldered, or reflowed? Was the device washed after? The Integration Guide covers details.
        Please contact me directly at: garrym@lantronix.com as this seems more of a HW issue than 'firmware' issue.

        Comment

        Working...
        X