Announcement

Collapse
No announcement yet.

Problems setting up XPicoWifi

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Problems setting up XPicoWifi

    We are using the XpicoWifi module in our devices and are having some problems that we are not able to solve.
    Normally our Wi-Fi devices, before delivering to the client, we test them without making big changes in the configuration of the XpicoWifi.
    That is, we see that we connect with your ap0, which works well as tunnel and little else.

    What I comment next happens in modules that I have tried (5 in this case taken at random) and some client has already happened in some supplied.

    On the one hand, something as simple as changing the SSID in the ap0 option is hard for us to do.
    It seems that the new name is saved but when disconnecting and reconnecting the module, it turns out that the ap0 is still identified with the default name "xPicoWifi ..."
    After many attempts we can finally get the new name entered, but sometimes it is impossible.

    On the other hand, if for example, we use the "QuickConnect" option and choose a network to connect to, many times the "ERROR: Insufficient space on file system" is shown, but the module is new and there doesn't seem to be a problem of space in "File System".

    Likewise, and as it happens with the ap0, it is almost always impossible to configure a module to work with wlan0 since the configuration does not remain saved when the module is turned off / on.

    In short, we have a hard time configuring the modules and I really do not know what may be happening.

    The versions of fw I've tried (and the same thing happens) are 1.3.0.1R4 and 1.4.0.0R28.

    Some idea?

    Thanks in advance.

  • #2
    It seems like there is a problem with the configuration file, which have happened during the firmware upgrade. Here's my suggestion:
    - Use the latest Alpha firmware: https://forums.lantronix.com/forum/x...ion-1-5-0-0a35
    - If you must use a released firmware instead, use only 1.4.0.0R28, not 1.3-based firmware.
    - After updating firmware, use the DEFAULT pin (hold down for over 6 seconds after the device has booted) to reset all the configuration to factory defaults.
    - Configure as needed.

    Mariano

    Comment


    • #3
      Thanks Mariano for your fast answer.

      I did what you told me but I did not get anything positive.

      Finally I discovered that it was a problem in the power supply of the modules, it was appliyng internally 2.3v instead of 3.3v.
      This caused all the mistakes I mentioned to you.

      Everything works now ok.

      Thanks again.

      Jordi

      Comment

      Working...
      X