No announcement yet.

Wifi Hotspot doesn't show up anymore after firmware update

  • Filter
  • Time
  • Show
Clear All
new posts

  • Wifi Hotspot doesn't show up anymore after firmware update

    After updating the firmware of the XPICO Wifi module it stopped showing the Wifi hotspot, so it's now impossible to connect to the wifi module.

    I tried to put back default settings by first pressing the reset button while holding reset pressed default button after that released the reset button to start default mode.

    Sadly this didn't help and we are still unavailable to connect to the wifi module.

    Is this problem solvable in another way?

    Many thanks for the help!


  • #2
    You can try "serial recovery" to the xPico wifi module. Please install Device installer and go to "Device Installer" -> Tools -> Recovery firmware -> Select correct com port you connected to the module and products. You can only do serial recovery by connecting the xPico wifi via serial line.

    Link to install Device installer:

    You can contact our technical support if you have any difficulty using Device Installer.

    Technical support:


    • #3
      Thank you for the quick reply, what is the best way to connect the Xpico to the computer. We have a connector where we can connect a USB cable to with D+ and D-. And the option to connect a USB to RX/TX cable, but with the first test, this didn't recognize the Xpico. Is there a guide how to connect Xpico to the computer via a cable? Thank you in advance!


      • #4
        Any answer for how to connect to the Xpico wifi? I cannot find any documentation about this. Thank you in advance!


        • #5
          To do serial recovery, you need to connect a COM port on your computer to the UART on the xPico Wi-Fi, including TX, RX, RTS, and CTS.


          • #6
            Hi Mariano,

            Thank you for your answer, we tried almost everything we could imagine but we cannot get a connection between our computers and the XPICO Wifi module via a serial connection.
            I will explain what we tried to establish a connection.

            We used a Serial converter cable from FTDI (
            Connected the TX, RX, RTS and CTS to the correct pins on the XPICO Wifi module. And we connected the USB cable into the computer which was found as COM port which we selected within the software.
            For some reason it tries to make a connection with XPICO wifi module but it never established this.

            I am wondering what I am doing wrong and what I should do to get a connection, because in the mean time it also happend to a second module and because of not having a wifi hotspot we cannot deliver 2 of our printers.

            Is it maybe possible that you send me the exact way to get a connection between a computer and the XPICO Wifi module. Maybe you have some guide with the steps to take and maybe we should use a different Serial converter cable.

            I hope you can help us out, many thanks in advance!


            • #7
              What's the message that the DeviceInstaller serial recovery utility shows?


              • #8
                I get the message "Please reset, power-on, or power-cycle the device..." We then reset the device by powering it on and of, and it will not recognise it.
                Looks like that it is not possible to recognise the XPICO wifi module.


                • #9
                  Can you post a screenshot? It should say:
                  [09:18:12.361] Changing serial port speed to 115200.
                  [09:18:12.367] Changing serial port flow control to 'None'.
                  [09:18:12.368] The defaults line must be asserted for about a second prior to reset or power-on
                  [09:18:12.901] Querying Device.
                  [09:18:15.177] Please reset, power-on, or power-cycle the device....

                  Are you holding the defaults line asserted for about a second prior to reset or power-on?


                  • #10
                    I can but that will take some time because I have to make the setup again. I will try to do it now. But I can tell you that I didn't assert the default line. So I need to do this before the startup?


                    • #11
                      Ok, just made the setup again. Before powering on the device I hold the Default pin low, let it startup and then let go the line. When I do that it still stays with the same message to reset the device.
                      Could there be anything else we are doing wrong?


                      • #12
                        I made the connections between the USB serial converter and XPICO wifi like this, hope this is also how it should be.

                        USB XPICO
                        RX -> TX
                        TX -> RX
                        CTS -> CTS
                        RTS -> RTS


                        • #13
                          I found out that connecting to RX2 and TX2 to the xpico I can make a connection. Should I have always done this or still try RX1 and TX1?
                          When using RX2 and TX2 I get message that i correctly send the rom file but then it is trying to send a carriage return to device which in the end results in a error.
                          I hope that you can help finalise the restore function of the xpico


                          • #14
                            I finally managed to Reprogram the Xpico wifi module. I will explain what I did to get it working.
                            First of all, the Xpico is connected to our microcontroller, I had to erase the microcontoller otherwise it was impossible to establish a connection.
                            After that I hooked up the cables from my FTDI serial converter to RX1, TX1, RTS1 and CTS1.
                            When running the recovery tool I kept the default pin low and then started up the Xpico. It did recognise the Xpico and started to do the update.
                            Sadly after the recovery I still could see the wifi network, but after some research I found out I had to upload a different .rom file.
                            I downloaded the [URL=""]xPico


                            • #15
                              Do you have "Hardware flow control" in xPico wifi? What is the error message from Device Installer?