I'm evaluating xPico WiFi using the Arduino shield package (standalone, so no Arduino). The chip is running firmware, with tunneling enabled on both Line1 and Line2 (always active, 115200 bps, 8 data bits, 1 stop bit, no flow control).

An off-the-shelf laptop acts as wireless client and is manually connected to the xPico SoftAP WiFi network. The laptop is also connected to J9 via USB cable. My test consists of sending small data packets (100 bytes, followed by a 1000msec delay) through the Line2 tunnel (laptop > "WiFi end" of xPico > J9 > laptop Com port).

After an apparently random time, the WiFi connection to xPico dropped. I tried manually reconnecting the laptop to the network, to no avail. I ran the same test several times and the connection kept dropping (after 15 minutes to about 20). Re-connection is not possible unless xPico is reset.

I ran a second test on Line1, after mounting the shield on an actual Arduino. In this scenario, Arduino generated the data packets and the laptop only acted as a "receiver" (no USB connected on J9). The results were the same.

Is this a known behavior?
What can I do to debug the issue?

If you need more information I'll do what I can to provide it.
Thank you in advance for any help you can provide.