Announcement

Collapse
No announcement yet.

How to scan for available Access Points from XML or POST command

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • How to scan for available Access Points from XML or POST command

    Is there a way to send a command via POST/xml to the Xpico to have it scan for and then list available WiFi Access POints in range?

    THe only way I can see to do this is via the Quick Connect in the web manager?

    I deally I would like to be able to send a POST to the module, wait a bit and then POST a gain to get the list of SSIDs, etc.

    Thanks for the help

    -jc

  • #2
    Hi jc,

    Yes there is. Take a look at the example called quickconnect.html that you can find here:
    https://github.com/Lantronix/xpwJSlib

    Specifically, you can see the code in the startScan and getScanResults functions in the Javascript library file:
    https://github.com/Lantronix/xpwJSli...ster/xpwLib.js

    Mariano

    Comment


    • #3
      That was just what I needed thanks!

      Another question - I am unable to use the keyValue "optionalGroupList" when doing POSTs to export/config. Im assuming this is a way to only retrienve that group and not the whole config XML?

      I have tried some of the smaples listed - specifically the one to retreive WLAN profiles and also the GPio Status but am getting the whole XML file.

      I am not using js as am developing for IOS. Have tried using Postman and am unable to get a subsection of the full Config file.

      The two I have tried are:

      url: /export/config
      key: optionalGroupList value: CPM CPs

      &

      key: optionalGroupList value: WLAN Profile

      Comment


      • #4
        Make sure that the key/value pair is being sent as part of the POST's body, in URL Encoded format, and the the Content-Type header is set by your HTTP client in iOS as application/x-www-form-urlencoded.

        Similarly, in Postman, make sure that in the "Body" tab of Postman you select the radio button for x-www-form-urlencoded, not the one for form-data.

        Mariano

        Comment


        • #5
          I have done the above - and it still sends me back the whole file.

          Comment


          • #6
            What's the version of firmware that you're running on the device? Also, can you try to run a Wireshark trace while you see the issue?

            You can email the Wireshark capture to the FAE for your region who can take a look at it and see why it's not working.

            Mariano

            Comment


            • #7
              I am using firmware version: 1.3.0.1R4

              re the wireshark trace - possibly a bit past my paygrade. I can download wireshark - but have never sued it and am unfamiliar with how I would set it up in this case...

              Comment


              • #8
                Ahh. Can you get on a newer firmware image? Current parts are shipping with 1.4.0.0R28:

                http://ltxfaq.custhelp.com/app/answers/detail/a_id/1781

                Or you could try one of the newer 1.5 Alphas that you can find on this forum.

                Comment


                • #9
                  Upgrading to the 1.4 version of the firmware has added the functinality to call just a specific group.

                  Is there documentation listing the optional command that can be issued via the parameters in the api calls?

                  Neither of the documentation for XML or Actions that accompany the new firmware mention the optionalGroupList parameter for example...

                  Thanks

                  -jc

                  Comment


                  • #10
                    Take a look at Chapter 5 of the User Guide which shows the options of how to use the WebAPI. The XML and Actions documents will have the actual groups that are available for those APIs.

                    Mariano

                    Comment

                    Working...
                    X