Announcement

Collapse
No announcement yet.

Trouble sending data to dweet.io with arduino

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Trouble sending data to dweet.io with arduino

    I have the Xpico wi-fi arduino shield and trying to recreate the dweet.io demo done by Marino on youtube (https://www.youtube.com/watch?v=xmrgD9j_iFA&feature=youtu.be)

    My arduino code is:

    Code:
    void setup()
    {
      Serial.begin(9600); // Initialize serial port to send and receive at 9600 baud
      delay(10000);                                          // delay 10 secs to allow xPico Wifi to boot up
      Serial.println("setup complete");
    }
    
    void loop()
    {
      
      Serial.print("GET /dweet/for/vano?potentiometer=9999 HTTP/1.1\r\n");
      Serial.print("Host: dweet.io\r\n");
      Serial.print("Connection: keep-alive\r\n");
      Serial.print("Accept: */");
      Serial.print("*");
      Serial.print("\r");
      Serial.print("\n");
      Serial.print("\r\n");
      
      delay(5000);
    }  // end of loop
    When using the arduino serial monitor i can see the correct output, but cannot see any changes on dweet.io website.

    I'm able to login to the Xpico wifi and connect to my local wireless network.
    Are there some settings that i need to change on the xpico?

    i've updated the xpico firmware to the latest 1.3.0.0R10 firmware, but still no luck.

    Thank you,
    ivan

  • #2
    Hi Ivan,

    What is the configuration of Line 1 for the xPico Wi-Fi? It needs to be configured to make a connection to dweet.io port 80. You could do a Tunnel with Connect Mode set to Any character. You'll also want to setup a disconnect timer so you don't keep the connection open).

    Also, where is the "setup complete" output going? If that's going to the xPico Wi-Fi's serial port and tunneled to dweet.io web server, it's going to create issues.

    Mariano

    Comment

    Working...
    X