Announcement

Collapse
No announcement yet.

Export /Import Settings of AR?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Export /Import Settings of AR?

    I am looking at putting the Xport AR into a product. Once I have everything setup properly in my test unit is there a way to then export the settings/firmware and upload them to production modules?

    Thanks for any help!

    Dion Brewington

  • #2
    Hi Dion,

    You can export the configuration in XML format. With any standard editor you can modify it, save it and apply it in the production to new XPort AR.

    There are XCR and XSR.
    The XCR contains the configuration. This is what you need for duplication the configuration
    The XSR are some status information like current values of the GPIOs.

    You can apply the XCR through telnet, ftp and the web browser from the network side and through the CLI from the serial side.

    A detailed description of the XML is in the Xport AR Command Reference. You can download it from http://www.lantronix.com/support/downloads/?p=MPORTAR

    The XPort AR comes already with a preloaded firmware. Usually there is no need to replace it.

    Peter
    Last edited by Peter; 02-22-2011, 11:47 PM. Reason: Fixed typos
    Lantronix FAE EMEA

    Comment


    • #3
      Peter,

      Thanks for your response. I will definately check that out. Shortly after that post I bricked my Xport AR and sent an email in. I have been comparing modules with a competitors and was experiencing a performance difference with the Xport. So I had the bright idea to turn off features I wasn't using to see if any of those were slowing down communication. I turned off telnet, ftp, and then turned off the webserver not thinking about the fact that it would disable the http configuration (it was midnight :^) . Now I cannot get back into the device. Device installer finds it and I tried to reflash the firmware but it pops up asking for the FTP username and password during the flash and does not accept the defaults (I had not changed them on this device). Any tricks on resetting the device? Telnet was turned off so I can't get in that way. The only other way I can think of right now is the recover firmware option in the device installer but I need to try and rig a cable to get a serial port connection.

      Comment


      • #4
        Sorry to hear that you have bricked the XPort AR.

        In Evolution the configuration is stored seperately from the firmware. So reflashing the firmware doesn't solve your problem.

        Since you have closed all network access (telnet, web manager, ftp) the only way reseting the config is through the serial line.

        When the XPort AR is booting you have to constantly send '!' until you receive a "!" back tahn you have to send "xyz" and you are in the CLI
        The serial interface is configured as 9600@8N1, no flow control

        Here you can either go through the menu and activate the web manager or you can reset the device to factory defaults. Reseting to factory defaults is done
        >>enable
        (enable)##reload factory defaults
        This command will destroy all configurable parameters and reboot.
        Are you sure you want to do this (yes / no)? yes
        Do you want to back out (yes / no)? no


        Reflashing the firmware through the serial side with the DeviceInstaller will also work as long as you checkmark the box "Erase All Flash"

        BTW if you are looking for a device with more processor performance you should consider the XPort Pro or the MatchPort AR.

        Peter
        Lantronix FAE EMEA

        Comment


        • #5
          Thanks Peter. I'll see if I can get that to work. The reason I chose the Xport AR was my device will need to send a email message with status information in the message body. When I looked at the specs on the Xport Pro I didn't see that. I haven't reached that point in my developement yet but I will need to be able to build a email with information from my microcontroller and send it. Does this seem doable with the AR/Pro? Eventually I will also need to display those values on a webpage on the built in server as well.

          Comment


          • #6
            Both the XPort AR and the XPort Pro are sharing the same operating system. So the features are pretty much the same.
            You can send out emails, but the body is limited to predefined content. With the standard firmware it is not possible to change this content.

            With the SDK you can add your own logic and send emails with any content.
            For embedding data on a web page you need the SDK anyhow.

            The XPort AR has more hardware interfaces
            - 1 serial interface versus 2
            - 3 GPIOs versus 11
            - RJ45 with PoE lines

            The XPort Pro has
            - much more RAM (8MB vs. 1.25MB) and Flash (16MB vs. 4MB)
            - a faster processor (32 bit Coldfire vs. 16 bit 186 core)
            - GNU development environment vs.Paradigm compiler.

            The SDK is in both cases free. But the XPort AR needs a specific compiler from Pardigm. The XPort Pro is based on GNU tools. The command line version is for free. An Eclipse based version is around $400.

            If you don't need the additional interfaces of the XPort AR, I recommend the XPort Pro. You get much more performance and memory for the buck

            Peter
            Lantronix FAE EMEA

            Comment


            • #7
              Peter,

              I found an issue with the Xport AR. What I have been experimenting with is using it to interface my device that has a bootloader with the PC and update the firmware on my device. Basically the pc is sending out around 64 bytes and then waiting for a ack byte. As I mentioned before the Xport was taking much longer than another brand. It turns out that the latest firmware has done something to cause this problem. If I load 5.2.0.0R21 it take well over 3 minutes to load my firmware. If I load 5.1.0.0R13 my firmware takes 1:48 every time. This is the same time as the other brand device. The new firmware also introduces enough delay that when using the lantronix com port redirector and my serial bootloader software it causes timeouts and my flash to fail half way through. Again, with the 5.1.0.0R13 the serial bootloader software works fine. So everything points to some added delays in the new firmware. I noticed two new settings under the LINE configuration in the latest firmware. One called GAP TIMER and the other called Threshold. I tried quite a few combinations with those options but still could not get the new firmware to speed up communication. Any ideas?

              Comment


              • #8
                Originally posted by Peter View Post
                You can apply the XCR through telnet, ftp and the web browser from the network side and through the CLI from the serial side.
                Hi, is There some examples how you can apply the XCR through telnet or ftp?.

                Something like:

                Telnet <ServerIP> XCR import configFile.xml
                ??

                Thanks.

                Comment

                Working...
                X