Announcement

Collapse
No announcement yet.

Php? :)

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Zac1209
    replied
    9 years later. Did you find any solution?

    Leave a comment:


  • Draconi
    started a topic Php? :)

    Php? :)

    I know I'm going to catch flak for this, but here goes anyway...

    Anyone able to get PHP (CGI or otherwise) working in SDK 2.0?

    I've been reading the posts here regarding other interpreted languages and one of the common responses is that the XPort Pro may not have enough RAM/Flash for it. Is this the case here?

    I've Googled this to death, and the best thing I've found is this link:
    http://www.menie.org/georges/uClinux/boa-php.html

    I've followed the instructions on the above link for both PHP 4.3.10 and even the older 4.3.4 patch, and both just give me grief (compile errors).

    I then tried the latest version (5.3.3?), but without a patch to give it the uClinux specific stuff, I really don't know enough about what to do to make it work. I can compile stuff on regular desktop Linux, but the specifics of the embedded side of things are a bit over my head.

    Even if it can be compiled and used with the "configure --disable-all" switch (to disable all extensions), I'd love to see it. This would at least give me a place to start and I can then attempt to add more stuff if possible (and provide that knowledge back to the community here).

    I realize there are other options which are more, um, optimized for the SDK... shell scripts, C/C++... but, for web apps, I'm really glued to PHP. I've got a large library of stuff I use for it, and quite frankly it's "just what I use". So please don't try to "guide" me towards another language.

    With all that said, please keep this on topic in regards to the question of "can PHP be compiled and used for SDK 2.0".

    Thanks all in advance
Working...
X