Announcement

Collapse
No announcement yet.

Feedback - installing Linux SDK on Ubuntu 9.04

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Feedback - installing Linux SDK on Ubuntu 9.04

    Some feedback about installing the latest version of the Linux SDK under Ubuntu 9.04 and hopefully might help others with a similar problem.

    I recently purchased an Xport Pro and Development board. I applied all the dendencies as detailed in the Linux SDK User Guide un Ubuntu 9.04.

    The install.sh script installed all the software correctly and I was able to run 'make menuconfig'. I could set the Vendor/Product Selection to Lantronix and Xport Pro, and set Customize Kernel Settings and Customize Application/Library Settings in Kernel/Library/Defaults section. On exit-ing and saving the configuration, the program stopped with the following error:

    [email protected]:~/xport_SDK$ make menuconfig
    cd /home/prf/xport_SDK/linux; make menuconfig
    make[1]: Entering directory `/home/prf/xport_SDK/linux'
    config/mkconfig > Kconfig
    KCONFIG_NOTIMESTAMP=1 /home/prf/xport_SDK/linux/config/kconfig/mconf Kconfig


    *** End of Linux kernel configuration.
    *** Execute 'make' to build the kernel or try 'make help'.

    ./.oldconfig: 1: -e: not found
    ./.oldconfig: 2: -e: not found
    ./.oldconfig: 3: -e: not found
    ./.oldconfig: 4: -e: not found
    make[1]: Leaving directory `/home/prf/xport_SDK/linux'
    [email protected]:~/xport_SDK$

    After much head scratching, the problem was narrowed down to the setconfig script under <sdk_installation>/linux/config:-

    **************************************************
    #
    # remove line containing $1 append line $2 to file in $3
    #
    replace_line()
    {
    TMPR="/tmp/setconfig.$$"
    if [ -f "$3" ]
    then
    cat "$3" | grep -v "$1" > "$TMPR"
    else
    touch "$TMPR"
    fi
    echo -e "$2" >> "$TMPR"
    cp "$TMPR" "$3"
    rm -f "$TMPR"
    }

    **************************************************
    If I edit the line echo -e "$2" >> "$TMPR" to echo "$2" >> "$TMPR" all seems to work and I can run 'make menuconfig' successfully, make changes to the kernel and applications and use 'make' to start compilation.
    I guess that the Ubuntu version of 'echo' doesn't support the -e option correctly. I experienced the same problem using Ubuntu 8.04 and 9.1.

    Regards
    Peter Foden, Proudman Oceanographic Laboratory, Liverpool, UK

  • #2
    I had to replace default /bin/sh link with bash to solve this.
    http://forums.lantronix.com/showpost...46&postcount=2

    Comment


    • #3
      Originally posted by prf View Post
      *** End of Linux kernel configuration.
      *** Execute 'make' to build the kernel or try 'make help'.

      ./.oldconfig: 1: -e: not found
      ./.oldconfig: 2: -e: not found
      ./.oldconfig: 3: -e: not found
      ./.oldconfig: 4: -e: not found
      make[1]: Leaving directory `/home/prf/xport_SDK/linux'
      I ran into the same thing on Kubuntu 9.10. Thanks for the post. I simply fixed it with a symlink /bin/sh -> /bin/bash

      --Mike

      Comment


      • #4
        Symlink alteration - Ubuntu 9.04

        Sorry for delay replying - been away for a couple of weeks.
        Thanks for your solutions, I tried changing the symlink as suggested but it seemed to already set. Not been able to make it work so far, perhaps I am updating the symlink incorrectly?

        --Pete

        Comment


        • #5
          Originally posted by prf View Post
          Sorry for delay replying - been away for a couple of weeks.
          Thanks for your solutions, I tried changing the symlink as suggested but it seemed to already set. Not been able to make it work so far, perhaps I am updating the symlink incorrectly?

          --Pete
          Pete, are you re-running the install.sh script after you make the symlink? If you do "ls -l /bin" or some such, you should see something like "/bin/sh -> /bin/bash", if you see that, you're good, you just need to run the install.sh script again after.

          --Mike

          Comment


          • #6
            By default Ubuntu now uses dash instead of bash, there is much debate about the pros and cons on the Ubuntu forum, but also a solution how to swap over to bash again. Although this may impact on other aspects ie speed and compilation times.

            https://wiki.ubuntu.com/DashAsBinSh
            https://bugs.launchpad.net/ubuntu/+s...ash/+bug/61463

            As you suggested earlier, I found that /bin/sh was linked to /bin/dash.
            I altered this to point to /bin/bash by doing 'sudo dpkg-reconfigure dash' and accepting the 'No' option.

            It can be altered back to 'dash' by running dpkg-reconfigure dash again.
            Many thanks for the help
            --Pete

            Comment


            • #7
              Originally posted by prf View Post
              As you suggested earlier, I found that /bin/sh was linked to /bin/dash.
              I altered this to point to /bin/bash by doing 'sudo dpkg-reconfigure dash' and accepting the 'No' option.

              It can be altered back to 'dash' by running dpkg-reconfigure dash again.
              Many thanks for the help
              --Pete
              That's good info, Pete, I didn't know about dpkg-reconfigure, thanks. It's probably the more correct way of doing it than just making the symlink because your way, it will persist through upgrades and what what have you.

              --Mike

              Comment

              Working...
              X