Announcement

Collapse
No announcement yet.

Disabling console output.

Collapse
This is a sticky topic.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Disabling console output.

    It may be desirable to disable console output on the target in order free up the use of the serial port for other purposes. This can be especially important with the XPort Pro, as only one serial port is provided. Access to the Linux command shell will still be possible through telnet (if the static or DHCP assigned IP address is known). Instructions for disabling console output for Linux and dBUG are given below.

    Disabling Linux Console Output
    To disable Linux console output, the console shell must be disabled, and kernel console messages suppressed.

    To disable the console shell, the /etc/inittab file will need to be edited. By default the last line of this file enables console output with:
    ttyS0::askfirst:-/bin/sh
    To disable console output, comment out this line by placing a '#' character at the beginning. Note that on systems using ROMFS for the root file system (default option), this file must be changed at build time. The inittab file is found under:
    <install_dir>/linux/vendors/Lantronix/<Platform>/romfs_extra/etc/
    Edit this file, perform a make from <install_dir>, and transfer the new image file to the target for the changes to take effect.

    Note that switching between enabling and disabling Linux console output is much simpler when using either a NFS or JFFS2 root file system, as changes to inittab can be made at run time.

    To suppress kernel console messages, it is necessary to append the string "console=" to the kernel command line. This can be done from the dBUG prompt with:
    set kcl <existing_kcl_string> console=
    Use the "show" command to confirm your changes. Changing the kernel command line can also be done from Linux with the dbug-config command (if included in the build) with:
    dbug-config kcl "<existing_kcl_string> console="
    Replace <existing_kcl_string> with the existing kcl string on your target.

    Disabling dBUG Bootloader Console Output
    To disable console output from the dBUG Bootloader, it is necessary to enable the "silentboot" option. This can be done from the dBUG command line with:
    set silentboot on
    Use the "show" command to confirm the change. The silentboot option can also be enabled through Linux using the dbug-config command (if included) with:
    dbug-config silentboot on

    Enabling the "silentboot" option will also disable the autoboot countdown. To get to the dBUG command prompt when "silentboot" is enabled, enter the <ctrl>-x sequence three times at the beginning of the target boot sequence (entering <ctrl>-x repeatedly at startup may be simpler for getting the timing right). Note that "silentboot" can also be disabled from Linux (telnet to the command shell may be needed if the Linux console is disabled) through dbug-config (if included) with:
    dbug-config silentboot off

  • #2
    What is the default login for the telnet command shell interface?

    Comment


    • #3
      Default root telnet password

      In case anyone else comes looking for the default password for root, I figured out that it is "root".

      Comment


      • #4
        is there more?

        I have the Linux console and dbug console both disabled and i still can't seem to change the anything related to the serial port in the s2e web interface. I am able to change all settings relating to port 2 but port 1 doesn't want to be changed. What am i missing?

        Comment


        • #5
          You need to enable s2e for both ports, via make menuconfig

          Under Lantronix Applications (accessed via Customize Application/Library Settings), select s2e-con-both.

          Default s2e serial port(s) --->
          ( ) s2e-none
          ( ) s2e-con1
          ( ) s2e-con2
          (X) s2e-con-both

          Comment


          • #6
            s2e still not working

            I have enabled s2e-con-both in the make menuconfig and have disabled the Linux console output and disabled the dbug bootloader console output. I still can't seem to be able to use both ports on the matchport box. As it stands now, if i select s2e-con2, i am able to change the setting to port 2 via the web interface. when i change the setting to s2e-con-both then neither on port 1 or port 2 settings can be changed. i also tried to select the other two setting in the menu s2e-con1 and s2e-none and was never able to change port 1 settings via the web interface. the settings in /mnt/flash/etc/s2e-ttys0.conf had been changed but they did not take effect. thank you for the help.

            Comment


            • #7
              I'm using Linux SDK 2.0 (Released at Aug 2010) on MatchPort AR. The both s2e are working on my environment.

              If you are using image.bin, is your environment as following?
              Code:
              / # ls -l /etc/s2e*
              lrwxrwxrwx    1 root     root           23 Jan  1  1970 /etc/s2e-ttyS0.conf -> /var/etc/s2e-ttyS0.conf
              lrwxrwxrwx    1 root     root           23 Jan  1  1970 /etc/s2e-ttyS1.conf -> /var/etc/s2e-ttyS1.conf
              / #
              / # ls -l /var/etc/s2e*
              lrwxrwxrwx    1 root     root           29 Nov 30 00:00 /var/etc/s2e-ttyS0.conf -> /usr/local/etc/s2e-ttyS0.conf
              lrwxrwxrwx    1 root     root           29 Nov 30 00:00 /var/etc/s2e-ttyS1.conf -> /usr/local/etc/s2e-ttyS1.conf
              / #
              / # ls -l /usr/local/etc/s2e*
              -rw-r--r--    1 root     root          260 Nov 30 00:54 /usr/local/etc/s2e-ttyS0.conf
              -rw-r--r--    1 root     root          260 Nov 30 00:54 /usr/local/etc/s2e-ttyS1.conf
              If not, please try "make clean", "make".

              Comment


              • #8
                I see what is wrong

                Ok, i see what my problem is now.
                / # ls -l /etc/s2e* = ls: /etc/s2e*: No such file or directory
                The file s2e-ttyS0.conf or s2e-ttyS1.conf does not exist in the /etc directory. This is only the case when i choose s2e-con-both. If s2e-con1 or s2e-con2 is chosen, the corresponding s2e-ttys0/1 is found in the etc directory. the other directories are fine when s2e-con-both. any more suggestions? thanks

                Comment


                • #9
                  Default Telnet Login in uclinux

                  The Default Telnet Login in uclinux is:

                  user: root
                  pass: PASS

                  Comment


                  • #10
                    XPort Pro Linux telnet root login

                    PASS appears in other places and was my first guess, but consistent with resnak's post I was rewarded by guessing "root" as the root password for telnet login. This is for a recent XPort Pro Linux, XPP1003000-02R Rev B14, date code 16W37.

                    Comment

                    Working...
                    X