Announcement

Collapse
No announcement yet.

HOW-to use an existing Evolution MatchPort AR or b/g Pro with the Linux SDK

Collapse
This is a sticky topic.
X
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • HOW-to use an existing Evolution MatchPort AR or b/g Pro with the Linux SDK

    The assumption is that you already installed the SDK on your Linux machine. If not, please follow the instructions in Chapter 4 SDK Installation Overview of the Quick Start Guide. The guides mentioned in this post are in the Documentation folder of the ISO image/CD.

    Beware: This will erase Evolution from your MatchPort.

    These are the steps to convert an Evolution MatchPort to Linux
    1. Replace Evolution with the Linux boot loader (Chapter 3, Installing dBUG)
    2. reset the MatchPort
    3. erase the remaining flash space with
      fl e 0x30000 0x3c0000 (for 4MB flash - original MatchPort AR)
      fl e 0x30000 0x7c0000 (for 8MB flash - Linux MatchPort AR or MatchPort b/g Pro)
    4. reset the MatchPort (to get dBUG in a well-defined state)
    5. configure dBUG (see Chapter 3, Basic Configuration)
    6. 'set autoboot flash' within dBUG
    7. 'set filename imagez.bin' within dBUG
    8. download and flash linux with 'dnfl imagez.bin' from within dBUG
    9. reboot


    Your MatchPort should now boot into Linux.

    If you want to convert the Linux MatchPort back to Evolution, boot back into dBUG and erase the flash with this command:

    fl e 0x20000 0x3d0000 (for 4MB flash - original MatchPort AR)
    fl e 0x20000 0x7d0000 (for 8MB flash - Linux MatchPort AR or MatchPort b/g

    Then you can use Lantronix Device Installer to restore one of the Evolution images posted on the Lantronix website.

    MatchPort AR with 4MB

    4MB of flash is the bare minimum of flash for Linux. If is not a recommended configuration.

    Depending on your requirements (no ROMFS?, no JFFS2?, resize both) you will have to adjust the preconfigured file system sizes. Take a look at Chapter 5 Default Flash Memory Map and Custom Layout in the User Guide. The kernel command line option mtdparts can be very helpful for your experiments.
    Last edited by lholowko; 07-23-2009, 06:01 PM.

  • #2
    Is this possible to do with Xport Pro, Evolution to Linux or vice versa?
    H/W: Xport Pro, Demo Board, Dev Board
    S/W: SDK 2.0.0.0, Ubuntu 10.4.1 on both x86_64 and x86
    Me : M.D. living in Stockholm, Sweden. Hacking hardware and software as a hobby, mostly for fun. Also using Arduino and OpenWRT.

    Comment


    • #3
      Yes, it's also possible on XPort Pro.
      The flash address is different, however, you don't need to erase flash by dBUG manually if you erase all flash by Device Installer when you write dBUG or Evolution's firmware.

      Comment


      • #4
        These instructions are not working for me. I have successfully flashed DBug to an XPort Pro running Evolution os. I used the sdk user guide.

        The XPort Pro can boot using image.bin via tftp. However, I receive an error when trying to flash the image.

        Below you will find the log from the serial terminal:

        dBUG> dnfl image..bin


        Address: 0x4001FF80

        Downloading Image 'image.bin' from 172.18.100.179

        TFTP transfer completed

        Read 2380928 bytes (4651 blocks)

        Must erase complete sectors (0x00080000 to 0x002DFFFF)

        Continue (yes | no)?

        Program not flashed - could not erase flash...



        By the way, it doesn't help using the "fl e" command to manually erase the flash area in question.

        Comment


        • #5
          Hi,

          I actually tried to put Linux image on my Xport Pro following your guideline. Mine is a Xport Pro with Evolution OS. But I encouter some problems so I want to switch back to Evolution OS but I can't detect my device on the network. Even searching by its MAC address, I can't find it. I can connect via serial port to the Xport Pro and see the dBUG. With DeviceInstaller, I've download back xport_pro_5_2_0_0_R20.romz and it was successfull. I even chechk "Erase all flash memory". I would like to know how what are the defaults settings for the Xport Pro bootloader dBUG for a Evolution OS device. I think I screw up thing in the dBUG. Thank you!

          Benoit

          Comment


          • #6
            The dBUG bootloader is a secondary bootloader used for the purpose of launching Linux. The Lantronix bootloader is the primary bootloader on the XPort Pro. If you used Device Installer's serial recovery mechanism to successfully flash the Evolution 5.2 image, dBUG is removed from the system.

            If Evolution is loaded on the XPort Pro, it may be necessary to use the !xyz method to get back in. Set the baud rate of your PC's serial connection to 9600 baud, 8 data bits, no parity, 1 stop bit, no flow control. Power on the XPort Pro while holding down the '!' character in your serial session. When '!' echos to the screen, enter xyz within 5 seconds. This should bring you to a CLI session. Note that !xyz is a type of safe mode, so not all applications will be running. Use the !xyz session to further investigate the issue. You can set 'command mode always' on line 1 and save the configuration to make serial port CLI access automatic after rebooting.

            Matt

            Comment


            • #7
              Hi Matt,

              Thank you for your reply. I tried to follow your steps but I was unable to connect to the XPort using your settings. I still see the dBUG prompt when resetting the XPP whenever I try to send ! over the line.

              This is what I see each time I'm connected via serial port to the XPP.
              External Reset

              ColdFire MCF5208 on the XPort Pro
              Firmware v4d.1a.1E-svn708 (Built on Apr 19 2010 14:21:37)
              Copyright 2006 Freescale Semiconductor, Inc.
              Lantronix Inc. 2007-2010
              Enter 'help' for help.

              Press any key to stop autoboot
              dBUG>
              With my PC connected to serial port of XPP with serial settings @9600 8N1 no flow control on Windows 7 with hyperterminal, I don't receive anything. But if I change baudrate speed to 115200, it shows text above.

              Before that, I successfully upload firmware Evolution OS to the device via DeviceInstaller.

              How do I figure iif Evolution is really loaded in the device?

              Ben

              Comment


              • #8
                If you are still seeing the dBUG prompt, then Evolution OS is not loaded on the device.

                Make sure you have the correct Evolution firmware image and that your serial port setup is correct, and then retry flashing the Evolution image via Device Installer's Advanced Recovery mechanism.

                Matt

                Comment


                • #9
                  Hi Matt,

                  I now have Evolution OS back to the device and it's now working. Thank you!

                  Ben

                  Comment

                  Working...
                  X