Announcement

Collapse
No announcement yet.

CONFIG_HIGH_RES_TIMERS=y

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • CONFIG_HIGH_RES_TIMERS=y

    Hello,
    For my project i have to use high resolution timers. As written in http://elinux.org/High_Resolution_Timers I set CONFIG_HIGH_RES_TIMERS=y and recompiled the kernel. Now i get 1 nsec timer resolution in /proc/timers_list, but boot up time of XportPro had risen to 2 minutes!!! Does anybody know where is the problem?
    Update: all standard NTP program besides ntpdate are malfunctioning to in this configuration
    Last edited by agenkin; 07-09-2015, 07:43 AM.

  • #2
    I suspect that you are now spending more CPU cycles in the timer ISR than you have available to run your code;-)

    Comment


    • #3
      Hi, garry0427, thank you for reply.
      The point is that I not using timers ISR (yet). I have proceeded the next steps:
      1. Clean the build, set default kernel parameters, build and load to XportPro. - works nice.
      2. Set CONFIG_HIGH_RES_TIMERS=y, re-build and load: boot up is very slow.
      Also, ntpdate program takes 30-40 sec. to synchronize time to NTP server instead of 5-10 sec. before.
      The ONLY change that been done - setting CONFIG_HIGH_RES_TIMERS=y
      Best regards
      Alex

      Comment


      • #4
        Sorry, I have no quick answer, so lean on the Linux community. For the code trail, I'd start with Linux-2.6.x/kernel/hrtimer.c and .../kernel/time/ and grep for HIGH_RES.

        Comment


        • #5
          I know this is an old thread, but I have the same problem. I need to use HIGH RESOLUTION Timers, and it seems like it BOOTS forever, and will not use the Serial Port.

          Did you ever find a solution?

          Comment

          Working...
          X