Announcement

Collapse
No announcement yet.

Cannot access xPort Pro after setting "Boot from flash"

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Cannot access xPort Pro after setting "Boot from flash"

    Hi,

    my xPort Pro was booting fine with the setting autoboot="Boot from network" in DBUG. But then I tried to set autoboot to "Boot from flash" and now I cannot access my xPort Pro anymore.

    Can you give a hint how I can get it running again? How can I set it to factory default?

    Regards,
    Tom

  • #2
    you should be able to break into the boot startup with any character on the serial port while dBUG is starting.
    If you have your code running correctly - via boot from the network - then you need to 'flash it' before you can use boot from flash. See the SDK manual - dnfl command.

    Comment


    • #3
      Hi garry,

      thanks for you response. I have tried to break into the boot startup by pressing a key in the serial terminal but it does not work and I also cannot see the DBUG output because I have set it to silentboot=on. The uclinux is alwas booting (I can see the boot screen outputs) but I cannot login since there is no login prompt shown.

      Regards Tom

      Comment


      • #4
        Sorry I'm confused. Silentboot is on - so, no boot messages should be on the terminal.
        Pressing a key at boot, does not stop into dBUG?? - yet you see 'something' on the terminal. What exactly?
        You said: uclinux is always booting
        If that is so - can you get to it over the network with telnet?
        If the device is available over the network - try netcon to reconfigure the dBUG as needed. .../hostsrc/netcon-terminal/netcon

        Comment

        Working...
        X