Announcement

Collapse
No announcement yet.

GDB debugging problem

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • GDB debugging problem

    So I've followed the instructions in the Linux User Guild pdf to get gdb debugging working on my XPortPro 16mb device and I'm having a problem.

    Here is what I've done:
    I enabled GDBSERVER via menuconfig.
    I'm booting my device via nfs root (but I don't think that matters)
    On the device I run the command:
    / # gdbserver :2345 /bin/pwc

    On the host systems I run gdb with the command:
    $ m68k-uclinux-gdb nfs/bin/pwc
    Followed by:
    (gdb) target remote 10.15.0.55:2345
    Remote debugging using 10.15.0.55:2345
    0x408a0044 in _stext ()
    (gdb) break main
    Breakpoint 1 at 0x408a0156: file /home/dev/builds/wallnet/lantronix/build-xport/linux/user/lantronix/planar/wallnet/pwc/pwc.c, line 188.
    (gdb) continue
    Continuing.
    Remote 'g' packet reply is too long: 4089ca140000000000000006408f7f38000000004089800440 8f06f6408f08d8408a0156408adec04089df344089ca004089 b7c840898004408adec44089dee000000000408a0158000000 00000000000000000000000000000000000000000000000000 00000000000000000000000000000000000000000000000000 00000000000000000000000000000000000000000000000000 00000000000000000000000000000000000000000000000000 0000000000
    (gdb)

    At this point GDB seems to think the app is running on the target but I don't think so.

    I've googl'ed the message "packet reply is too long" message and most people indicate it that it's a missmatch in gdb and gdbserver's understanding of the target architecture but I have yet to understand what to do about it.

    So I'm hoping that someone other there has some in sight on how to get this working.

    Thanks,
    Matt S.

  • #2
    Solved my own problem a mere minutes after posting here.
    In menuconfig there are 2 GDBSERVER options that can be enabled
    gdbserver & gdbserver (old)
    I foolishly thought that I needed to enable the, presumably, newer but it turns out that I needed to enable the (old) one.
    Things seem to work now. Although I am seeing GDB report the following 2 warnings:
    warning: Target reported unsupported offsets: Text=409a0040;Data=409a68a4;Bss=409a68a4;

    warning: RMT ERROR : failed to get remote thread list.

    I don't know anything about the first and for the second I suspect I'll have trouble should I try to use threads.

    Matt S.

    Comment

    Working...
    X