Announcement

Collapse
No announcement yet.

s2e in server mode requires port to be restated by webpage configuration

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • s2e in server mode requires port to be restated by webpage configuration

    All,

    I have added code to s2e.c to implement a Modbus TCP server and onboard datalogging for our serial device. There is a problem that I cannot not solve - I think that the problem existed before I modified s2e.c. After the XPort boots up, it will not send packets, until I access the tunnel configuration webpage and set the port to 5000, send, then set it back to 502, and send.

    When I telnet into the XPort after it boots, and look at the default configuration file, /etc/s2e-ttyS0.conf: the port is set to 502 and all other parameters are OK. But it will not send packets until I restate the port twice (or once, if the port is set to 5000 initially).

    Parameters: Server Mode, Host address 192.168.0.19 (meaningless for server mode?), TCP, port= 502

    Is there a workaround for this? Thank you.

  • #2
    problem solved

    Thanks to y_hamada for answering this on 11-30-2010. The problem was - on startup, s2e was not running because I had checked "s2e-manually". Restating the port manually starts s2e. I unchecked "s2e-manually" and now s2e is started automatically. Mr. Hamada's post:

    You can configure to start s2e automatically as following:

    Code:
    $ cd <linux_sdk_install_dir>
    $ . env_m68k-uclinux
    $ make menuconfig

    Kernel/Library/Defaults Selection --->[*] Customize Application/Library Settings
    <Exit>-<Exit>-<Yes>

    Lantronix' Applications --->
    [ ] s2e-manually
    <Exit>-<Exit>-<Yes>

    $ make

    Comment

    Working...
    X