Announcement

Collapse
No announcement yet.

DeviceInstaller 4.2.0.4 Error

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • DeviceInstaller 4.2.0.4 Error

    I'm getting an interesting error on my builds when I update the firmware and/or click on my Matchport AR device in DeviceInstaller 4.2.0.4 as follows:

    "The configuration could not be retrieved from teh device.
    System.ArgumentOutOfRangeException:Index was out of range. Must be non-negative and less than the size of the collection.
    Parameter name: index
    at
    Lantronix.Platforms.Evolution.XPort.XPortARDevice. GetConfigurationViaXML()
    at Lantronix.Platforms.Evolution.XPort.XPortARDevice. GetConfiguration()
    at DeviceInstaller.Form1.processNodeSelect(TreeNode node)"

    Is this something to be expected with custom applications or added SNMP commands?

    Windows 7 issue?

    Thanks,
    trostals

  • #2
    There are no known issues with this combination of DI and MatchPort AR.

    Let me check with a DeviceInstaller engineer.

    Comment


    • #3
      I spoke with a DI engineer, and even had him re-run some basic tests with DI, on Window 7, and using the FW version you have. We are not seeing any problems here (of course :-).

      Can you give us any additional info? Does it happen 100% of the time? Did it ever work? Does DI see the device, but fails to upload? ...

      Is it an option for you to provide a network (wireshark) trace on the failing session? That would be best and allow us to see exactly what is going on between the device server and DeviceInstaller.

      mattmc

      Comment


      • #4
        I have seen this error on firmwares where I have change the config.h file to use custom product codes. Have you changed config.h?

        Comment


        • #5
          Bummer, I didn't see an email for your replies.

          Yes, I have customized the config.h to have our companies desired firmware version and short and long description.

          #define DEFAULT_SHORT_NAME "FLX"
          #define DEFAULT_LONG_NAME "Leviton Monitored FLX PDU"
          #define IMAGE_NAME "MonitoredPDU"

          #define CUSTOMER_VERSION_STRING "L2.00"

          Comment


          • #6
            To answer the other questions in the post, the firmware upgrades still work.

            Just some of the device detail properties are missing.

            Comment

            Working...
            X