Announcement

Collapse
No announcement yet.

Error while trying to update firmare via tftp

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Error while trying to update firmare via tftp

    I am trying to update the firmware using custom update code from the SDKmain. The new image is uploaded to the xPort, the file is verified and then while trying to trigger the firmware update using tftp (as recommended in http://forums.lantronix.com/showthread.php?t=126 )I am getting the error code 10 (TFTP_ERROR_CODE__NOT_DEFINED).

    The simplified code from the SDKMain is:

    Code:
    char *fileNameLocal = "firmw.romz";
    char *fileNameXPort = "xport_pro.romz";
    char *tftpServer = "127.0.0.1";
    enum tftp_error_code tftpResponse;
    tftpResponse = TFTPPut(tftpServer, 0, 69, fileNameLocal, fileNameXPort, TFTP_MODE__BINARY);
    The firmware is uploaded to the local filesystem in XPort Pro, the file is verified (we check MD5 of the image elsewhere in the code).

    I tryied as well the IPs 127.0.0.100 and xPort's eth0 IP address with the same result.

    Any hint how to make it work?

  • #2
    Solved

    The problem was solved (thank for hint to Peter, Lantronix Germany) - there should be enabled firmware update for the internal TFTP server in the xPortPro. Either using web interface or via xml configuration.
    The xport tftp server is accessible on localhost IP address, 127.0.0.1.

    Comment


    • #3
      Does your code is available or is it a proprietary project ?

      I'm currently working on this topic and I plan to do the following :

      -open a socket on port 80 on my "distribution" server
      -do a http query (http query harcoded in my case) (write on the socket), then read the reply and store it in a local file.

      I wonder if I will face any size limitation (stack of the thread that do this download from my server to the xport pro) and if I need to read (on the socket)/write (in the file on the local file system) small packets or if I can get the "full" romz file at once ?

      I have found the following code that I'm trying to adapt to EOS SDK :
      http://coding.debuntu.org/c-linux-so...le-http-client

      Comment

      Working...
      X