Announcement

Collapse
No announcement yet.

Network Time Protocol (NTP or SNTP)

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Network Time Protocol (NTP or SNTP)

    Does anybody know if there's a way to use NTP or SNTP with the Xport PRO device?

    In case it is possible? Is there any library available?

    I really think this is an interesting feature and very usefull in the industrial devices we are developing with the Xport Pro integrated.
    XPort Pro newbie

  • #2
    See this post: http://forums.lantronix.com/showthread.php?t=182

    For some reason a search on "NTP" didn't turn anything up, but "network time protocol" did.

    mattmc

    Comment


    • #3
      Hi Matt,

      the search needs at least words with 4 letters, witzh 3 letters or less you get the error message

      Sorry - no matches. Please try some different terms.

      The following words are either very common, too long, or too short and were not included in your search : NTP


      Peter

      Lantronix FAE EMEA
      Lantronix FAE EMEA

      Comment


      • #4
        LOL. I guess I should actually take the time to read the error message.

        Thanks Peter.

        mattmc

        Comment


        • #5
          Dreuu, the post that was referenced is an excellent one. I can personally vouch that it works very well. I currently have an NTP implementation running on an XPort-Pro that works very nicely.

          J

          Comment


          • #6
            Thanks

            Sorry for my late reply... Just want to thank you all for the help and the answers. Will try to implement it and post the result here.
            XPort Pro newbie

            Comment


            • #7
              Hello Joshjack and dreuu,

              Could you please tell me how have you configured NTP on xport pro.

              I have followed below steps didn't worked

              1) Enabled NTPD from kernel/Application settings.
              2) Added ntp.conf inside LantronixSDK/linux/vendors/Lantronix/Xport_Pro/romfs_extra/etc
              3) Added command to 'start' file (at the end):
              /bin/ntpd -c "/etc/ntpd.conf" also tried /bin/ntpd -c "/etc/ntp.conf"
              ('start' file located in /linux/vendors/Lantronix/Xport_Pro/romfs_extra/etc)
              4) Through web configuration i changed Protocol: to UDP.

              I checked from Wireshark software, but i am not seeing any request raised from Pro and response.

              Thanks
              harshith

              Comment

              Working...
              X