Announcement

Collapse
No announcement yet.

SNMP agent: strange answer to multiple values GET

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • maxximo62
    started a topic SNMP agent: strange answer to multiple values GET

    SNMP agent: strange answer to multiple values GET

    Hi,

    I am developing an SNMP agent using the "XPort-Pro SDK" and my environment is

    -) HW : XPort-Pro
    -) FW : Evolution OS V5.2.0.1.R5

    I'm facing a strange behaviour of the agent when it receives a multiple values GET command sent from the NMS.

    I used snmpget (http://www.net-snmp.org/wiki/index.php/TUT:snmpget) and on Xport Pro I loaded the custommib.c example.

    The request I sent is

    snmpget -v 2c -c public 192.168.10.147 .1.3.6.1.4.1.991.99.1.1.0 .1.3.6.1.4.1.991.99.1.2.0 .1.3.6.1.4.1.991.99.1.3.0 .1.3.6.1.4.1.991.99.1.4.0 .1.3.6.1.4.1.991.99.2.1.1.1.0 .1.3.6.1.4.1.991.99.2.1.1.1.1 .1.3.6.1.4.1.991.99.2.1.1.1.2 .1.3.6.1.4.1.991.99.1.1.0 .1.3.6.1.4.1.991.99.1.2.0 .1.3.6.1.4.1.991.99.1.3.0 .1.3.6.1.4.1.991.99.1.4.0

    and the answer I got from the agent is

    SNMPv2-SMI::enterprises.991.99.1.1.0 = INTEGER: 13
    SNMPv2-SMI::enterprises.991.99.1.2.0 = STRING: "String value from the custommib.c SDK sample."
    SNMPv2-SMI::enterprises.991.99.1.3.0 = INTEGER: 42
    SNMPv2-SMI::enterprises.991.99.1.4.0 = INTEGER: 0
    SNMPv2-SMI::enterprises.991.99.2.1.1.1.0 = INTEGER: 0
    SNMPv2-SMI::enterprises.991.99.2.1.1.1.1 = INTEGER: 1
    SNMPv2-SMI::enterprises.991.99.2.1.1.1.2 = INTEGER: 2
    SNMPv2-SMI::enterprises.991.99.1.1.0.2 = INTEGER: 2
    SNMPv2-SMI::enterprises.991.99.1.2.0.2 = ""
    SNMPv2-SMI::enterprises.991.99.1.3.0.2 = INTEGER: 42
    SNMPv2-SMI::enterprises.991.99.1.4.0.2 = INTEGER: 2

    The problem arises when a request concerning an OID contained into a table is followed by a request concerning another OID not included in any table.
    It seems the agent appends last row index to the right address.

    How can I overcome this behaviour?

    Thanks.

    Regards
    Max

  • gary_marrs
    replied
    There is a bug in the SNMP agent in SDK version 5.2.0.1R5.

    This problem has been fixed with a BETA release V5.2.0.2B13 SDK

    Leave a comment:

Working...
X